TORONTO KIDS COMPUTER CLUB | Tuesday 17:30 Python Homework 21.03.02.
19122
post-template-default,single,single-post,postid-19122,single-format-standard,ajax_fade,page_not_loaded,,qode-theme-ver-7.6.2,wpb-js-composer js-comp-ver-6.10.0,vc_responsive

Tuesday 17:30 Python Homework 21.03.02.

03 Mar Tuesday 17:30 Python Homework 21.03.02.

Reminder: Next Class will start from 5:15pm

Question 1:

A soccer team is looking for girls from ages 10 to 12 to play on their team. Write a program to ask the user’s age and if male or female (using “m” or “f”). Display a message indicating whether the person is eligible to play on the team.

Sample Input 1:
Age: 10
Gender: f

Sample Output 1:
Welcome to the team!

Sample Input 2:
Age: 10
Gender: m

Sample Output 2:
You are not allowed to play!

Question 2:
Continue coding the program we did in the class, so the program will:

  1. Assign a color to you base on the height you entered
  2. You can also ask about the zone you would like to play, the program will tell you whether you can pay in the zone base on your color:

height

color

zone

if<90

red

1

elif<105

blue

1, 2

elif <120

green

1,2,3

elif <135

yellow

1,2,3,4,5

elif <150

purple

4,5

else

white

6

Please continue coding the following program:

print('Welcome to the adventureland!')
while True:
    h = int(input('Height:'))
    if h < 90:
        c = 'red'
    # continue your program to assign color 

    print('your color is', c)

    zone = int(input('Zone to play(1-6): '))
    if zone == 1 and c != 'purple' and c != 'white':
        print('You can play in zone 1')
    # continue your program to see if you can play in the zone 
No Comments

Sorry, the comment form is closed at this time.