TORONTO KIDS COMPUTER CLUB | Summer Camp 2021 Python Homework 13:30 – week 04
19753
post-template-default,single,single-post,postid-19753,single-format-standard,ajax_fade,page_not_loaded,,no_animation_on_touch,qode-theme-ver-7.6.2,wpb-js-composer js-comp-ver-6.10.0,vc_responsive

Summer Camp 2021 Python Homework 13:30 – week 04

31 Jul Summer Camp 2021 Python Homework 13:30 – week 04

Question 1:

A store is having a sale. They’re giving 10 percent off purchases of $10 or lower, and 20 percent off purchases of greater than $10. Write a program that asks the purchase price and displays the discount (10% or 20%) and the final price.


Sample Input 1:
How much: 10

Sample Output 1:
You got 10% discount and your final price is $9

Sample Input 2:
How much: 15.5

Sample Output 2:
You got 20% discount and your final price is $12.4


Question 2:

A soccer team is looking for girls from ages 10 to 12 to play on their team. Write a program to ask the user’s age and if male or female (using “m” or “f”). Display a message indicating whether the person is eligible to play on the team.

Sample Input 1:
Age: 10
Gender: f

Sample Output 1:
Welcome to the team!

Sample Input 2:
Age: 10
Gender: m

Sample Output 2:
You are not allowed to play!


Question 3:

Continue coding the program we did in the class, so the program will tell you whether you can pay in the zone:

height

color

zone

if<90

red

1

elif<105

blue

1, 2

elif <120

green

1,2,3

elif <135

yellow

1,2,3,4,5

elif <150

purple

4,5

else

white

6

Please continue coding the following program:

print('Welcome to the adventureland!')
while True: # this line means forever
    height = int(input('Height:'))
    if height  < 90:
        color = 'red'
    elif height  < 105:
        color = 'blue'
    elif height  < 120:
        color = 'green'
    elif height  < 135:
        color = 'yellow'
    elif height  < 150:
        color = 'purple'
    else:
        color = 'white'

    print('your color is', c)

    zone = int(input('Zone to play(1-6): '))
    if zone == 1 and color != 'purple' and color != 'white':
        print('You can play in zone 1')
    # continue to code below

No Comments

Sorry, the comment form is closed at this time.